22 октября 2009 г.

php5-5.2.9 has known vulnerabilities при установке PHP5


root# cd /usr/ports/lang/php5
root# make install clean
===> php5-5.2.9 has known vulnerabilities:
=> php5 -- Multiple security issues.
Reference:
=> Please update your ports tree and try again.
*** Error code 1

Stop in /usr/ports/lang/php5.
*** Error code 1

Stop in /usr/ports/lang/php5.


Насколько я понял, в пакете нашли уязвимость и в целях безопасности установку заблокировали с рекомендацией ждать обновляя порты. Так или иначе если ждать не получается, всё решаемо:

root# cd /usr/ports/lang/php5
root# make DISABLE_VULNERABILITIES=yes install clean

Комментариев нет: