3 ноября 2009 г.

Установка ISPManager под Debian 5 (Lenny)

... — это неимоверный пиздец.
За тот потраченный вечер я наконец до конца понял всю соль утверждения, что во FreeBSD всё обходится без пионерства и красноглазия. И пока (цитата) «админы-freebsd'шники пьют пиво, дебианщики мучаются и не спят ночами». Впрочем, можно и не согласиться: дебиан — охуенная система. Но каким бы лучшим он ни был, я не собираюсь тратить бесценные нервы, грея себя мыслью о стройной системе пакетов apt. Я поставлю себе целиком стройную, заточенную под серверные нужды, операционную систему, и сэкономлю зрение. Так-то...

UPDATE 05.11.2009: звучит, конечно, нелогично, но после всего я таки поставил ISPmanager, и именно наDebian 5.0.3 "Lenny". Главное — перед установкой настроить /etc/apt/sources.list (желательно добавить туда зеркало Яндекса и локальное зеркало Дебиана), а затем выполнить apt-get update и apt-get upgrade. Содержимое моего sources.list:
deb http://ftp.ua.debian.org/debian/ lenny main contrib non-free
deb http://mirror.yandex.ru/debian/ lenny main contrib

После этого панель начинает ставиться. На стадии выбора ПО я указываю custom, а затем отмечаю только www, nginx, php, smtp, quotas, dns. Это — в соответствии требованиям к серверу. Пакеты ставятся, потом тестятся, и почти все вылетают с ошибкой ERROR на этапе тестов. Ну и насрать, захожу в панель, пересоздаю пользователя (иначе WWW-домены не добавляются), создаю основной домен, перезапускаю сервер. Всё работает.

И, да, есть одни грабли: если вы заходите на http://ip/manager/ispmgr и видите страницу nginx с ошибкой 404, зайдите не по http://... а по https://...

UPDATE 24.03.2011: Снова вернулся к вопросу установки ISPmanager под Debian 5, и раз уж такое дело -- опишу здесь этот процесс.

Сначала проверим лицензию: http://lic.ispsystem.com/ispmgr.lic?ip={IP}

Заходим root-ом на сервер, закачиваем установщик и выполняем его:
wget "http://download.ispsystem.com/install.sh"
sh install.sh

Видим следующее:
ISPsystem install v.4

1) ISPmanager-Lite
2) BILLmanager-RUCENTER
0) Exit

Please choose software to install:
Выбираем продукт, который необходимо установить.
Please choose software to install: 1

Указываем ближайшее зеркало для закачки полного архива с панелью:
1) ru.download.ispsystem.com
2) us.download.ispsystem.com
3) be.download.ispsystem.com

Please choose mirror to install from:

Указываем какую ветку устанавливать -- стабильную или beta.
1) beta version - has the latest functionality
2) stable version - time-proved version

Please choose version to install:

Дальнейшие шаги расписаны на официальном сайте ISPsystem. Быть может, потом я опишу их здесь сам.

Комментариев нет: